Mandrill MX: Invalid

I’m experimenting with Mandrill and every domain I’ve added, including some I added months ago, were showing “MX: Invalid”. The MX records were in place, for one domain, they were in place before I added the domain to Mandrill.

When their support helpdesk got back to me, the solution was simple. I had to click the “Test” button next to each domain. What a PITA. I waited a couple of days to click a damn button that I found no reference to in their documentation. Bah humbug.

Oh well, it’s working now. 🙂

4 thoughts on “Mandrill MX: Invalid”

  1. hi

    can u please suggest me what does it mean…make sure only Mandrill domains are in your MX record: beyondmarketvalue.com…

    is my mx reccords added or not..

    thankx

  2. I am using Mandrill successfully for other sites. I have just added your WP Mail SMTP plugin to a Wp blog and activated a new API key for the blog in Mandrill. I did everything in the WP admin but when I sent a test email to an address, your plugin’s debug shows the following errors:

    [“language”:protected]=>
    array(18) {
    [“authenticate”]=>
    string(35) “SMTP Error: Could not authenticate.”
    [“connect_host”]=>
    string(43) “SMTP Error: Could not connect to SMTP host.”
    [“data_not_accepted”]=>
    string(30) “SMTP Error: data not accepted.”
    [“empty_message”]=>
    string(18) “Message body empty”
    [“encoding”]=>
    string(18) “Unknown encoding: ”
    [“execute”]=>
    string(19) “Could not execute: ”
    [“file_access”]=>
    string(23) “Could not access file: ”
    [“file_open”]=>
    string(33) “File Error: Could not open file: ”
    [“from_failed”]=>
    string(35) “The following From address failed: ”
    [“instantiate”]=>
    string(36) “Could not instantiate mail function.”
    [“invalid_address”]=>
    string(15) “Invalid address”
    [“mailer_not_supported”]=>
    string(25) ” mailer is not supported.”
    [“provide_address”]=>
    string(54) “You must provide at least one recipient email address.”
    [“recipients_failed”]=>
    string(45) “SMTP Error: The following recipients failed: ”
    [“signing”]=>
    string(15) “Signing Error: ”
    [“smtp_connect_failed”]=>
    string(22) “SMTP connect() failed.”
    [“smtp_error”]=>
    string(19) “SMTP server error: ”
    [“variable_set”]=>
    string(30) “Cannot set or reset variable: “

    1. The error message suggests there was an authentication failure. I’d suggest resetting / verifying both the username and the password. Failing that, it might be an issue around the type of authentication methods that are allowed. Is the SSL option also set to the same as your other sites which do work? Are those sites on the same server (same PHP config, firewall, etc)?

Leave a Reply

Your email address will not be published. Required fields are marked *